Vauxhall Owners Forum banner
1 - 20 of 33 Posts

·
Registered
Joined
·
30,330 Posts
i remember i badgered animal for this lovely black distributor cap i saw gleaming amongst all his stuff when he was at bracknell. the electrodes were perfect, plently of meat on the centre pin, genuine bosch cap and black sleave still on it. went home took the 15 quid pattern cap off, put the "new" one on and the car wouldnt accelerate past 4500rpm, almost like someone had dropped the rev limiter. if you crept up to it, it was fine, but press on and it was bad.
 

·
Registered
Joined
·
30,330 Posts
your first mistake is trying to remove the cap from the the equation because its new, or it "was ok". if theres one thing ive learnt with engine tinkering and computer tinkering is never try and rationalise the unrationable !
 

·
Registered
Joined
·
30,330 Posts
like the time i bought a new modem for my computer, a few days later if found out that the very hour i installed it, the ISP server had some downtime. queue 2 days of me troubleshooting my new modem that i thought didnt work.
 

·
Registered
Joined
·
3,438 Posts
Discussion Starter · #14 ·
0ddball said:
like the time i bought a new modem for my computer, a few days later if found out that the very hour i installed it, the ISP server had some downtime. queue 2 days of me troubleshooting my new modem that i thought didnt work.
Yeah but u weren't to know it was down.

Anyway, what else could cause it?
 

·
Registered
Joined
·
8,449 Posts
It really sounds like its misfiring, buy another cap and rotor arm - they will get used in the future when you need to replace them, so it wouldnt be a waste of money if they didnt solve the problem IMO.
 
1 - 20 of 33 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top