Vauxhall Owners Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
2,914 Posts
Discussion Starter #1
Had a great time today, and had quite a few runs up the strip. My best time was 15.00 sec at 96.81mph, had a few others runs close to that time, and some not so close lol! due to traction problems off the line and the clutch slipping when activating the nitrous! Will have to get the progressive controller on I think, should give better results.
Also had one run where i completly screwed up on the gear change to thrid, ended up with 17.2 lmao
was good though, had plenty of runs, met some new poeple and some very nice cars on show!

My new front tyres after quite a few runs lol!















































 

·
Registered
Joined
·
83 Posts
Hello again Phil.
You'll remember me from the Wizards of NOS forum and that I run a similar but heavier motor with 75bhp NOS with no controller.
I was there on the Sunday and ran 14.8 @ 96mph FYI. That should make a good benchmark as you will be instantly quicker as soon as you are ready to change to 75bhp jets.
I didn't have to much of a problem with traction, but did have clutch slip on the gearchange and had to change to 4th just before the finish line, although bigger wheels will sort that next time.

 

·
Registered
Joined
·
2,914 Posts
Discussion Starter #5
yeah im going to wire in the minimax controller and change to 75bhp jets, think I will try and position the injector much closer to the throttle body aswell, ive just got a feeling its not performing as well as it could do when using the nitrous. was hoping to get into the 14s, controller should help the clutch out a bit aswell lol
 

·
Registered
Joined
·
7,580 Posts
Nice pics :D

I was standing next to bicco when you were talking to him btw :)
 

·
Registered
Joined
·
2,108 Posts
Nice to have met u Phil, your car looks as good in the metal as it does in the pics I've seen before. I'm sure it will really start to motor as soon as u get the gas and clutch sorted :)
Talking of pics why cant I see the ones in this thread?
 

·
Registered
Joined
·
2,914 Posts
Discussion Starter #12
for some reason my tripod webspace isnt working! so pics arnt, even though I can upload and download the pics cant access the website!

Anyway was nice to meet you mate, liked your engine bay!
 
1 - 12 of 12 Posts
Top