Vauxhall Owners Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
542 Posts
Discussion Starter · #1 ·
After fitting and setting up these topmounts on my Corsa B ive noticed that when I spin the steering wheel the bearings in the topmounts are not spinning with the dampers etc. This means the coilover topcup is spinning against the sleeve spacer in the bottom of the bearings and its the same for both sides? The top sleeve nuts came loose after a week so I nipped it to a garage to have them done up with a wizzy gun and they have been the same ever since!
 

·
Registered
Joined
·
8,862 Posts
are the sleeve nuts and spacers maybe a little bit long, ie they are tightening up together but not gripping the center ball part of the mount??

Seems odd as the bearings are quite easy to turn and much smoother than std ones.
 

·
Registered
Joined
·
542 Posts
Discussion Starter · #4 ·
No I dont think so. None of the sleeve nut top&bottom parts or the actuall ball or piston rod is spinning as the coilover legs turn with the steering. If I put a socket on the top nut it will spin with the bearing ball & piston rod but its not easy to turn, gets easier if I jack the corner up but still not exactly 'free'.

The tophat/topcup of the coilover does spin with the leg along with the spring but it appers as though where the tophat faces upto the bearing sleeve they are spinning against one another which surely isnt good? Why the bearing isnt just spinning with the lot ive no idea!

One posibility is that the mechaninc has done the top nut up so tight that is ovalised the ball making the bearing tight but that would need to real force surely?
 

·
Registered
Joined
·
1,647 Posts
WeeKenny said:
yes but he has ***ked up somewhere.
I'd say it may not be his fault........one of the spherical bearings I have is impossible to rotate and is very stiff in it's angular range of movement. This is without it being fitted to the top mounts. I've asked NRE about this and I am hoping for a reply.

:beer:
 

·
Registered
Joined
·
542 Posts
Discussion Starter · #8 ·
Mine were like that too! One was easy the other was stiff but its fine when you have them fitted. Anyhow, I stripped them all down yesterday afternoon to take a good look whats going on. Bearings move fine, if a little stiff but ive found the problem.

With my Spax RSX coilovers the tophat is free to slide the length of the piston rod (piston rod dia = 20mm, tophat hole dia = 20mm).

Now whats happening is that the TAS sleeve spacer is butting up nicely against the top shoulder of the piston rod (M12, out to 20mm dia), thats fine. But their isnt enough shoulder on the sleeve spacer to then give a good face to the tophat, only about 23-24mm dia on the sleeve spacer so the tophat is just spinning against it!

Its a trip to the machinists for some new ones with larger bottom dia, or get some new undrilled tophats, bore the bottom out to 20mm then the top to M12 - giving the tophat an internal shoulder which can then butt up against the top of the piston rod (ie sandwitch the tophat tight!)

So for reference anyone wanting to use TAS topmounts with Spax RSX - it isnt a straight fitment!
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top