Vauxhall Owners Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
7,141 Posts
Discussion Starter #1
I have put a 20 XE engine in my Cav SRi.

I have wired up most of the XE loom now but the wiring to the coil seems different. The XE one has a four pin connector coming out of the end of the injector rail. The SRi Coil has 2 two pin connectors.

The 4 pin XE connector has:

Red with black trace
Red
Black
Green

The SRi coil connections are:

Green
Black
Red - going to a suppressor or something bolted to the bodywork

My question is, what do I do?

Also, I have a single connector coming out of the XE loom at the end of the injector rail (end with the hall sensor plug and Coil plug) that I cannot find a home for. The connector is a single green wire with a black plug on it.

Any ideas?
 

·
Administrator
Joined
·
29,659 Posts
erm do you onyl need the little moduley bit for the loom to plug into that sits below the coil or is it new coil time

me being a dumbass didnt resuce it off the car
 

·
Registered
Joined
·
7,141 Posts
Discussion Starter #5
Well I was thinking about cutting the Green and Black wires out of the 4 pin ECu loom and hooking them up to the Green and Black 2 pin connector from the SEH loom and plugging it into the coil and see what happens. If that doesn't work then I think it will be new coil time.
 

·
Registered
Joined
·
15,614 Posts
No No No.

You need the little module with the red & blue wires coming out of it. You connect them upto the coil.

and the 4 pin connector on it to the ecu loom 4 pin plug.

They were fitted to 20XE and C20LET's and some of the late MK2 carbed cavs not that you will find many at the scrap yards now
 

·
Registered
Joined
·
7,141 Posts
Discussion Starter #7
Nice one, cheers Andy, that saves me a headache.

So are you saying that I should get looking for a coil from a 20XE. This should then plug straight into the 4 pin plug on the loom?

Straight swap kinda thing?

Sorry, it's getting late and I am cold and tired from being outside working on the motor all evening.
 

·
Registered
Joined
·
30,330 Posts
from what i understand from andys post, you need an XE coil, then the module between the XE coil and the 4 pin plug on the loom.
 

·
Registered
Joined
·
7,141 Posts
Discussion Starter #9
Bugger, So I have to try and locate two different things now?

Daz, fancy popping round tomorrow night so I can have a brief look at yours?
 
1 - 13 of 13 Posts
Top