Vauxhall Owners Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter #1
Plot

Above is my Rolling Rd plot for my mk3 Astra SRi 2.0 8v. Its low on power

Ram-air induction kit is all i have do to the engine but when driving there are alot of flat spots as the graph show, I am about to de-cat it but will this sort it out???
Please can you give your opinions on this, what else is needed to gain the lost power and get a smoother curve

Cheers
Si
 

·
Registered
Joined
·
9,415 Posts
injectors may need cleaning!!

run it on high octane fuel ie 97 or 98 ron.

and put a 220 ohm resistor in line on your water temp sensor, you wont believe the difference, if you dont believe me ask

Astramad or
Toby C.

also sri cams are supposed to be quick to wear out a new one may make a big emprovement.

oddball is a very knowlegable chap on these engines too.
 

·
Registered
Joined
·
12,574 Posts
i got same car as you
mine was also down on power (107bhp)
heres a pic of my graph

 

·
Registered
Joined
·
56 Posts
Discussion Starter #5
I'll have a look into those FSE valves.

Vxlgsi: Whats this about a 220 ohm resistor on water temp sensor, anymore info u can give. What does this mod do?

Adam Sri: I see you were down on power but u dont have the flats spot i seem to have :confused:
 

·
Registered
Joined
·
30,330 Posts
they are monster flat spots, like 10bhp drop kinda flat spots. you sure it wasnt wheel spinning then snatching grip again ?

If that is a genuine representation then its gotta be eletrical or fuelling.

No offence to vxlgsi but all that resistor will do is fool the ecu into thinking coolant is colder than it is and overfuel, thats no fix for this problem, bit of a blunt instrument.

If it was me i'd do a service as already stated, plugs, leads, cap, rotar, get the injectors cleaned (not fuel additive stuff)

are you sure its actually the 130bhp engine, and not the C20NE 115bhp one ? doesnt matter what you think should be in the car, check out the engine stamp.
 

·
Registered
Joined
·
56 Posts
Discussion Starter #10
Its the 115bhp C20NE engine, the other was put in the Cav SRi.

Please can u help Oddball coz i know nothing about those graphs, The wheels weren't spinning off the rollers. I can feel the flat spots when driving, feels like something is pushing me back when accelerating!!??!! :(
 

·
Registered
Joined
·
30,330 Posts
actually the engine data sheets i have do not have a C20SEH or C20SER, just as i thought. If it has a cat, it has to be the 115bhp C20NE.

Also, just checked EPC and the only 2 litres engines fitted to mk3's were C20NE (115bhp) C20XE (150bhp) and X20XEV (136bhp)
 

·
Registered
Joined
·
56 Posts
Discussion Starter #14
Ok, me thinks ur saying to get a nice big service done?? lol

But iv only just have a service about 2500miles ago, I'll have a another and get the injectors cleaned. Whats involed in cleaning the inductors? Flush?
 

·
Registered
Joined
·
4,644 Posts
If it was me i'd do a service as already stated, plugs, leads, cap, rotar, get the injectors cleaned (not fuel additive stuff)
get the injectors ultrasonically cleaned, not using the 'fluid' injector cleaner crap like Wynn's
 

·
Registered
Joined
·
30,330 Posts
they plug them into an ultrasonic pressurised cleaning system, its squirts cleaning fluid through while operating the injectors thousands of times a minute (on off, on off)
 

·
Registered
Joined
·
30,330 Posts
when we said a service, we dont mean a garage type service where they change the oil and chuck a new air filter in.

you need things like fuel filter, rotar arm, distributor cap, spark leads, spark plugs, (injectors cleaned)
 

·
Registered
Joined
·
56 Posts
Discussion Starter #20
ok cool, cheers guys. I'll RR it again in next couple of months and see if she goes better.

How do u guys rate these FSE valves then, or is it the same as the water temp mod?
 
1 - 20 of 25 Posts
Top