Vauxhall Owners Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
10,228 Posts
Discussion Starter · #1 ·
my nova has been off the road bing fixed at a garage
the fault found as duff crank sensor
a new one has been fitted but now another fault has appeared
low fuel pressure it's showing 12.5 i'm not sure if it was psi?
blokey at garage recons it should be 30
what can cause the pressure to be low he is testing it on the tyre valve type thing on the fuel rail
it's running a 1.2i in tank pump which has been fine for 4 months
it also wouldn't rev over 4k easily when it was running bad before the crank sensor packed in
 

·
Registered
Joined
·
18,393 Posts
the fuel pressure regulator might have summat to do with it. dunno what 2.5 bar is in psi, but its meant to be that (suppose it about 30)
they are about £100, or replace with fse etc
 

·
Registered
Joined
·
10,228 Posts
Discussion Starter · #6 ·
so the 1.2i nova pump will be ok aslong as the filter(s) is clean, how does the regulator work, cause the pipe going to it was split and i replaced it and it made no difference :rolleyes:
and hey caved and mr. 8v you live close enough to me to help :D
 

·
Registered
Joined
·
18,393 Posts
well......by the weekend i should have a 2.5 bar regulator to sell (nice 3 bar on its way and this one works! :D ) by sell i mean £5!!!

what garage you using? they any good? i got a good garage near ellesmere port if you need

i am busy with work all week but if you do desparately need a hand, post up and i can pop over at the weekend :p

[ 17-07-2001: Message edited by: 8vastra.co.uk ]
 

·
Registered
Joined
·
18,393 Posts
ah ****, i knew there was summat...the fuel pump for the 1.2 is only 1 bar, so thats more likely your problem come to think of it :rolleyes: totally forgot that when writing the 1st message!!!! :eek:
 

·
Registered
Joined
·
1,336 Posts
I`ve got a spare reg aswell.Also got the correct guages for testing the fuel pressure in the rail.If what rob is saying is right(1.2i fuel pump being 1 Bar)that is only 15 Psi!Give us a shout if ya need help as i`m only 10 mins away.
 

·
Registered
Joined
·
10,228 Posts
Discussion Starter · #12 ·
yeh but it may only be 1 bar but it did 15sec 1/4mile over in york and i've had an indicated 145mph out of it, so it can't be running that bad??
can i try clamping the return to see if the pressure backs up?? if it does then i can suspect the regulator
p.s. my mate has a 1.2i pump on a 2.0 16v with no problems!!
 

·
Registered
Joined
·
17,928 Posts
Hey I'd be a bit concerned about using a 1.2 pump for a 2L engine. The bigger engine's going to want twice as much fuel!

Things to consider:
pump probably struggling to keep up with demand when you rev it out
fuel filter blocked/old
fuel flow damper blocked(dome shaped bit next to filter(
pressure regulator dying
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top