Vauxhall Owners Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
3,671 Posts
Discussion Starter · #1 ·
After finding out she was a bit down on power the other day ( due to leaning out at the top end )I`d changed a few sensors (CTS/TPS/Knock) & since shes been running rough.

The problem starts at about 4250rpm, it seems to lose all power, it will pull through it but struggles & then has the same prob at 6000rpm. It doesn`t seem to do it 1st & 2nd only 3/4/5/6th. I did find the exhaust was blowing badly but thats since been sorted & its not helped. I tried putting all the old sensors back on to see if that helps & its no different.

The only other thing I`ve changed is the gear linkage & I can`t see that`d have any relevance to the current problem.

Any ideas, its getting annoying now, the turbo`d one proving as problematic at the supercharged one.

Cheers

Rich
 

·
Registered
Joined
·
9,160 Posts
Kin'ell where to start. If you can, do a compression test. Check/change the fuel filter and check the fuel pressure. Are you able to borrow a air flow meter to try?
Read the fault codes?
 

·
Registered
Joined
·
3,671 Posts
Discussion Starter · #3 ·
For some reason the fault codes won`t come up.

Done a compression test & its fine, changed the fuel filter about a month back & the fuel pressure gauge in the car isn`t ready anything out of the ordinary. I even tried changing plugs/leads/cap/arm, may try a different dizzy 2morrow.

AFM is the only thing i`ve not got spare
 

·
Registered
Joined
·
3,671 Posts
Discussion Starter · #4 ·
Checked pretty much evverything again today but still no luck.

Any other suggestions
 

·
Registered
Joined
·
3,489 Posts
Exactly what mine used to do, stick in Optimax and it pulls strongly to 6k.
 

·
Registered
Joined
·
3,671 Posts
Discussion Starter · #6 ·
The Optimax may be worth a go, nearest ones 50 miles from me though.
 

·
Registered
Joined
·
3,489 Posts
Joy said:
The Optimax may be worth a go, nearest ones 50 miles from me though.
Any high octane fuel should perform as Optimax does. It'll cost you a few quid more for a tank full, but worthwhile running your tank low and trying some just to find out.
I was suprised at the difference.
 

·
Registered
Joined
·
3,671 Posts
Discussion Starter · #8 ·
I`ve always used octane booster before (CVL Turbo) but have been off week for a week or 2 & haven`t been able to get any recently.
 

·
Registered
Joined
·
3,671 Posts
Discussion Starter · #9 ·
Just taken it out for another run, this time with a different dizzy (I took the old one off & loads of white plasticy/ceramic chunks fell out). Seems a little better ie it pulls through the flat spot a lot quicker but I`m still baffled as to why its fine in 2nd (haven`t tried 1st as it jsut lights up straight away).

I`m still slighty suspicious of the TPS I changed but I can`t get a new one till Wednesday when I get back to work.

Looks like its off to Taunton for a tank of Optimax this afternoon, I`ll see if that helps.
 

·
Registered
Joined
·
34 Posts
It may be worth getting the ECU tested to see if the unit its self is working as it should. I had my astra's ECU checked once as my car was running a bit odd and it was found that one of the components had shorted out. If the ECU is faulty in anyway it could easily fool you as to what is at fault.
 

·
Registered
Joined
·
3,671 Posts
Discussion Starter · #11 ·
The Optimax hasn`t cured the main problem but it feels better through the working rev range.

I`m gonna get a new TPS on weds if that doesn`t work a mates got a spare AFM/ECU so I`ll try that.
 

·
Registered
Joined
·
3,671 Posts
Discussion Starter · #13 ·
I`ve tried a few sets of plugs, all with diff gaps, between 0.6mm - 1.1 mm doesn`t seem to help & misfire up the top end on the 1.1mm`s.

I may get a new set in a day or 2.
 

·
Registered
Joined
·
3,671 Posts
Discussion Starter · #14 ·
It`s still bloody doing it, new TPS, air temp sensor, new water injection jet. It also struggles revving for the first minute or to but it stops when she warms up ?

New plugs should turn up tomorrow & I`ve got a spare knock sensor somewhere

Only things I`ve not got spare to try is ECU/AFM
 

·
Registered
Joined
·
3,671 Posts
Discussion Starter · #16 ·
I`ve done a compression test but it show up fine across the board but i suppose it could be a different story when under boost. The coolant smells normal, nasty but normal.
 

·
Registered
Joined
·
591 Posts
how come the fault codes wont flash up, is the bulb ok, not been wired to another ignition light to fool you?
 

·
Registered
Joined
·
3,671 Posts
Discussion Starter · #18 ·
Can`t find why the fault codes won`t come up,its all there, i`ve checked the wiring, changed bulb & instrumant panel no luck.

Changed the plugs today & its no better, to make it worse on my way back from work some ******* cut me up & i`ve mangled one of my freshly powder coated Speedline Mistrals.
 

·
Registered
Joined
·
3,671 Posts
Discussion Starter · #20 ·
I just got back to work this week, just had 2 weeks off, AFM is one of the few things I`ve not got spare.
 
1 - 20 of 23 Posts
Top