Vauxhall Owners Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
1,357 Posts
Discussion Starter · #1 ·
Hi, Since i bought my Cav Turbo i have noticed it runs hot all the time even when on a run. The fan cuts in every few mins and cools it back down. the temp never gets above 3/4 but still the Fan is Always on.

Yesterday i bought a Cool running thermostat from Courtenay Sport and it arrived today. I fitted it, but still have the same running temperatures with the fan coming on all the time.

My old calibra did not suffer with this problem at all and it has me a little confused and concerned as to what the cause can be.

The head Gasket was done a little over 12 Months a go.

I have checked the Oil and water and the car is using neither of these, The oil is still clean and the water is a Perfec Blue/Green with the antifreeze and is showing no signs of oil and water mixing, so shows no evidence of a headgasket problem, + the car goes too well.

Anyone got any ideas?

Cheers.
 

·
Registered
Joined
·
30,330 Posts
well atleast the stat change proves its some deficiency in the cooling system. maybe a blocked rad, shafted water pump, air lock. maybe even the engine running lean. maybe the fan switch is shafted.
 

·
Registered
Joined
·
1,357 Posts
Discussion Starter · #3 ·
I will flush the Radiator and cooling system on monday and see how that is.
I would say it is not the fan switch as i put in a new temp sensor to check the temp guage was right and the engine temp is going up so it is not just a case of the fan coming on.
The car was only just Mot'd and the emissions was at 2.0% so that would eliminate it running lean would'nt it?

0ddball said:
well atleast the stat change proves its some deficiency in the cooling system. maybe a blocked rad, shafted water pump, air lock. maybe even the engine running lean. maybe the fan switch is shafted.
 

·
Registered
Joined
·
1,357 Posts
Discussion Starter · #6 ·
I know the Run hotter but this one seems a lot compared to my Calibra Turbo that i sold a few weeks ago. That never run hot when driving on Motorway just when standing. But the Cav gets hot on the motorway at 70Mph constant.
This just does not seem right to me.
 

·
Administrator
Joined
·
29,659 Posts
my turbo has never run hotter per the guage than the XE in my astra or the XE in my cav gsi with standard thermostat

cool running thermos are a waste of time as engine run better when at the designed operating temperature as i found out when running a cool thermo
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top