Vauxhall Owners Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
939 Posts
Discussion Starter #1
My cav turbo is overfuelling again! Its not the CTS this time. I did get lambda sensor code (13) a few times but if i reset the ECU the mileage on the trip computer would rise to where it should be about.
After a while driving i notice it starts going down loads really quick .i.e. if i go a couple of miles not even booting it, it'll go down 5-6 and it never used to!

It always seems to get better by taking off battery for a bit then reconnecting, and then it'll just go back to being crap again :mad: :confused:
The wires from the sensor look fine, its not even THAT old either. What else could cause overfuelling? Its drinkin too much and seems as though im always going to the petrol station!! :mad:
 

·
Registered
Joined
·
9,160 Posts
Hard to say really,could be the lamda probe or maybe fuel pressure(too high).
High idle may just be a sticky icv. Remove it and try cleaning it out with carb clean the lubing it up with wd40,empty out the remains and reift.
 

·
Registered
Joined
·
195 Posts
Sounds like the idle control valve to me. Give the throttle body a good clean and make sure the butterfly is spotless!, it's worth getting the throttle body off!
 

·
Registered
Joined
·
939 Posts
Discussion Starter #5
Would the ICV cause it to drink so much though? Thought that would just affect the idle speed. Funny thing is, i took out a plug today but they were "normal" colour :confused: There was a bit of "soot" around the outer rim of the plug from before but the electrode was normal!

EH???! :confused:
 

·
Registered
Joined
·
9,160 Posts
Are you sure its overfuelling. Have you had the emmisions tested? Maybe its not actually overfuelling,could you possibly have a faulty trip and or fuel guage??
 

·
Registered
Joined
·
939 Posts
Discussion Starter #7
Pretty sure its overfuelling, both the gauge and T.C go down alot quicker, even without booting it. And taking off battery and resetting ecu makes the "range" go back to what it should be about. The average MPG hasnt gone over 20 for ages and used to be around 25! What could cause it to read wrong then? :confused:
Have got my MOT on friday too so would like to get it sorted before that

Oh and wheres the ICV? :eek:
 

·
Registered
Joined
·
425 Posts
change the lambda
brothers astra was doing around 15 miles to the gallon and at the mot had HC of almost 600 changed the lambda sensor now doing 35 +
 

·
Registered
Joined
·
195 Posts
Is the engine standard or have you made any mods? The ICV in attached to the side of the throttle body, a little black box.

Could very well be the cam sensor, I had a rover vitesse turbo, with a few mods and that was doing about 20mpg, turns out it was the cam sensor! The ecu engine check light didn't come on. Does your light come on with the ignition then go out again?
 

·
Registered
Joined
·
939 Posts
Discussion Starter #10
Yeah the light comes on and goes off as normal! If i reset the ecu and then start it up and drive it, the light will sometimes come on a couple of times if i give it more than 1/2 throttle then it'll go out and wont come on again, thiink this was code 13 (lambda) but its weird how it wont come on again after that :confused:

Engine is standard bar D.V, filter & 'zorst. :D
 

·
Registered
Joined
·
939 Posts
Discussion Starter #12
Well its only holding 6psi constant so cant really comment on the down on power bit lol At the moment its not using as much fuel after pulling around lambda wires etc so i reckon its gotta be that. ;)
 
1 - 12 of 12 Posts
Top