Vauxhall Owners Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
mpower

my c20xe power is low after 4000 rpm
TagsNone

Jump to LatestUnfollow

1 - 1 of 1 Posts



[IMG alt="mpower"]https://www.migweb.co.uk/d2/avatars/m/111/111201.jpg?1657401288[/IMG]
mpower
·Registered
Joined 12 h ago
·
1 Posts
Discussion Starter · #1 · 11 h ago

hello every body
i have c20xe on ascona b 77
the problem start after the dirty fuel go inside the fuel filter and coming from other side ( not original filter) and the dirty fuel with oil and rust maybe going inside the fuel pump ... so thats cus i notice the power jumping all time .and in the same time the car start from first try even after 10 days of stop. so i change the fuel filer and clean the injectors and everything ..and still same .. so after i clean the idle valve and change the spark plugs the car is 90% is ok ... but now when i press and go .. its ok but after 4000 rpm i feel the power coming like waves not full of power .. i feel like i pull the hand brake during push and drive ..
do you think guys the fuel pump have a damage and not work 100% ??
or the afm ??
or what 😭 this photo what i found inside the fuel filter from both side
 

·
Registered
Astra G 3.2 V6, Vectra Hearse 1.8
Joined
·
295 Posts
I had a flat spot for quite some time at a few thousand RPM and it was down to the fuel pump itself.maybe worth checking or replacing judging by what you have told so far. process of elimination seems to be the only part you have not replaced yet
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
I had a flat spot for quite some time at a few thousand RPM and it was down to the fuel pump itself.maybe worth checking or replacing judging by what you have told so far. process of elimination seems to be the only part you have not replaced yet
X AUTOHAUX fuel pump
Blue Cylinder Cable Electric blue Auto part
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #8 ·
add me if you want ( huss mpower )
and the engine work fine now :)
it was electric problem .. i found two wire have a weak point ..i fix them and it run great now with out replace fuel pump
 
1 - 8 of 8 Posts
Top