Vauxhall Owners Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
233 Posts
Discussion Starter · #1 ·
I have a 2007 corsa-D 1.2 Design petrol manual. The symptoms are Speedo and fuel guage reed zero. Odometer does not change and there is a solid 'F' (not flashing) displayed in the area of the mileage readout. Also the ABS Light is on.
The car seems to run fine and I have carried out an OBD2 fault check. This shows no faults.
I have read losts of post about the tiptronic F problem and older faults for when the dash plug came loose, but this does not fit these symptoms. The rev counter is working. as are all the other lights on the dash. The engine management light is not on and I have checked every fuse.
Any ideas would help before I start on the next set of testing.

ABS sensor - as this could be linked to both speedo and ABS light, but why the Fuel guage?

ABS unit again could be linked to electronic speedo.

Any help would be great thanks.
 

·
Registered
Joined
·
1 Posts
I have a 2007 corsa-D 1.2 Design petrol manual. The symptoms are Speedo and fuel guage reed zero. Odometer does not change and there is a solid 'F' (not flashing) displayed in the area of the mileage readout. Also the ABS Light is on.
The car seems to run fine and I have carried out an OBD2 fault check. This shows no faults.
I have read losts of post about the tiptronic F problem and older faults for when the dash plug came loose, but this does not fit these symptoms. The rev counter is working. as are all the other lights on the dash. The engine management light is not on and I have checked every fuse.
Any ideas would help before I start on the next set of testing.

ABS sensor - as this could be linked to both speedo and ABS light, but why the Fuel guage?

ABS unit again could be linked to electronic speedo.

Any help would be great thanks.
did you ever fix this happend with mine
 

·
Registered
Joined
·
2 Posts
I have a 2007 corsa-D 1.2 Design petrol manual. The symptoms are Speedo and fuel guage reed zero. Odometer does not change and there is a solid 'F' (not flashing) displayed in the area of the mileage readout. Also the ABS Light is on.
The car seems to run fine and I have carried out an OBD2 fault check. This shows no faults.
I have read losts of post about the tiptronic F problem and older faults for when the dash plug came loose, but this does not fit these symptoms. The rev counter is working. as are all the other lights on the dash. The engine management light is not on and I have checked every fuse.
Any ideas would help before I start on the next set of testing.

ABS sensor - as this could be linked to both speedo and ABS light, but why the Fuel guage?

ABS unit again could be linked to electronic speedo.

Any help would be great thanks.
My Speedo works but my fuel gauge goes to full then after about 0.1 miles it goes to nothing and shows the F on the dashboard, I have had an abs issue for a while, don't know wether that is related, if so why has it taken so long for the fuel gauge to stop working? Have you got a solution yet
 

·
Registered
Joined
·
1 Posts
I had same problem with No speedo, no fuel guage, abs light an F sign on dash. problem were cables broken on both sides under the bonnet brackets left and right side.
 
1 - 8 of 8 Posts
Top