Vauxhall Owners Forum banner
1 - 20 of 20 Posts

·
Registered
Joined
·
5,407 Posts
Discussion Starter · #1 ·
Driving along in a 40 zone earlier sitting dead on 40 and the car just died on me. Didn't press anything like the accelerator and the orange light came on the dash along with the oil and battery light. This never happens when accelerating or anything else. It only does it when sitting at a constant speed. Normally when the car is warm.
Changed the Fuel Relay and Throttle position sensor aswell. Still no luck.
 

·
Registered
Joined
·
1,444 Posts
Checked that your timing belt is intact? Try and start the car, and have someone look in the rocker cover via the oil filling cap and see if the cams are moving. Either that or turn the crank sprocket with a E20 socket (better idea, using the starter could knacker pistons further).
 

·
Registered
Joined
·
5,407 Posts
Discussion Starter · #6 ·
could it be something like the fuel filter? But the bit that makes me think it isn't that is the fact that it doesn't do it when accelerating which should be using more fuel. If i tank it to 115mph and then keep it at that it is fine. It also does it when sitting at 70 or 80 aswell. so it is a thing that is all across the gear range.
 

·
Registered
Joined
·
5,672 Posts
Well it wouldn't do any harm to change the filter..did mine just recently and car seems to go better (did it out of routine maintenance, rather than any problem though).Remember to de pressurise the system first!
Could be ECU.....dodgy lead....think it will be a process of elimination
 

·
Registered
Joined
·
5,407 Posts
Discussion Starter · #12 ·
how do i depressurise the system 1st? also where my fuel filter is, the bracket that holds the fuel filter is so corroded it will snap off if i try and force the nut off.
 

·
Registered
Joined
·
5,407 Posts
Discussion Starter · #13 ·
could i get an ECU from a scappy? off an 1.4spi and just replace it with mine? or does it need reprogramming? also does it have to be from a 1.4spi or can it be from a 1.4mpi?
 

·
Registered
Joined
·
5,672 Posts
Oakey22 said:
how do i depressurise the system 1st? also where my fuel filter is, the bracket that holds the fuel filter is so corroded it will snap off if i try and force the nut off.
Soak the screw/nut overnight with WD40 or penetrating oil...if it won't budge ,you may get lucky and be able to wiggle the filter out from the bracket(once you undo and remove one hose + mole grip)

For my Cav I removed the fuse for the fuel pump and ran the engine until it died , turned the engine over a few times to make sure it wouldn't start.
Used two small flat nosed mole grips to gently clamp the hoses both sides of the filter then removed. Make sure you make a note of how it comes off. There should be an arrow on the filter showing flow direction. Used new jubilee clips (get the right size , so you don't tighten them out of shape)

Fitted the new filter with flow arrow in same direction ,tightened jubilee clips then removed mole grips ...last op is to replace fuse for pump, start up and check for leaks
 

·
Registered
Joined
·
5,672 Posts
Oakey22 said:
could i get an ECU from a scappy? off an 1.4spi and just replace it with mine? or does it need reprogramming? also does it have to be from a 1.4spi or can it be from a 1.4mpi?
Don't know too much about ECU's but would assume you need one from the same spec of car
 
1 - 20 of 20 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top