Astra H ESP FAULT
+ Reply to Thread
Results 1 to 3 of 3

Thread: Astra H ESP FAULT

  1. #1
    MIGWeb User
    Join Date
    Mar 2003
    Location
    Gloucester
    Posts
    238
    Drives
    Astra SRI 1.9 CDTI 150BHP

    Astra H ESP FAULT

    Hi Everyone

    my poorley car Astra H sri cdti, 46k



    Driving car the other day and the ESP light came on, the triangle with the pic of the car and two skid lines in it , Ive noticed the light is coming on then sometimes goes off but now mainly its staying on . what also is really weird is that when the light comes on not only is the traction control not working but the indicators go wrong ie I have to manualy cancel them .


    anyone have any ideas what could be wrong or what to try ?

  2. Remove Advertisements
    MigWeb.co.uk
    Advertisements
     

  3. #2
    MIGWeb User
    Join Date
    Jul 2009
    Location
    uk
    Posts
    1
    Drives

    Angry Re: Astra H ESP FAULT

    Hi

    My car is also an Astra H SRI but with a prototype VXR engine putting out about 210 BHP. It was one of 5 prototypes made in Nov 2004 and intended for show room use.

    Driving it the other day the ESP light came on.
    My local dealer quoted 1247.99 inc VAT for the replacement part and about 160 + vat for fitting.

    The light stays on all the time and I can't say I notice anything else in normal driving.
    The car feels a bit unstable when I push it a bit so it looks like a real error.

    I decided that spending 1400 on a car just short of 5yo and valued at just over 5000 (when fixed), was a bad idea (especially with MOT and new tires due soon), so reluctantly I am selling it in part exchange for a new car.

    Heartbreaking! but the new one should be here at the end of the month!

  4. #3
    MIGWeb User
    Join Date
    Mar 2003
    Location
    Gloucester
    Posts
    238
    Drives
    Astra SRI 1.9 CDTI 150BHP
    Thread Starter

    Re: Astra H ESP FAULT

    are you sure they quoted the right thing ?

    mine turned out to be the SIM sensor that goes behind steering wheel , common fault apparently , anyway the part was like 360 odd i think and about 150 on top of that fitted.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts