Vectra GSi HELP WANTED!!!!
+ Reply to Thread
Results 1 to 6 of 6

Thread: Vectra GSi HELP WANTED!!!!

  1. #1
    MIGWeb User
    Join Date
    Jun 2006
    Posts
    2
    Drives

    Vectra GSi HELP WANTED!!!!

    Vectra GSi 2.6V6 Engine Management light on


    Hello fellow vauxhall enthusiasts.....

    Can somebody help me please??

    We have a 2001 51 plate 2.6 GSi Vectra Estate (Quite rare car) We have had it since August 2004 so was not quite 3 yrs old when bought.

    As it was a hard car to find, it was bought from an independant used car retailer, not through Vauxhall dealer network.

    The car had done 64k when purchased, and was returned to the dealer for a few teething problems, commeon things such as knocking from susspension, and eventually after saying all GSi s do that, they changed bushes and front steering linkages, problem solved. It took them longer to sort the other problem though which was with filling the tank of fuel to the top. It would only fill 3/4 full. They changed the tank twice, unblocked breather, and changed sender units for gague but in the end was another breather up in the wheel arch? they said was blocked. Problem solved again. However, about a month after the EML came on, not flashing but permanently on. once again we took it back and were told cat effeciency low, bank 2. a lambda sensor was needed. As we had bought a 5 star 3 year RAC warranty, they asked us to claim under that. However, although catalyst is covered the sensors are not, this was going to cost nearly 200 on top of the 10k we had just paid for the car!As that dealership use the RAC for all their warranties, they spoke to them and they offered a good will gesture of 100, so nearly 50% of the cost. Not too bad.

    However, within 150 miles the light was on again, and returned to the supplying dealer at this point they did not know what to suggest, as they checked the fault code (Same one up again) and the diagnostic equipment showed all the sensors working correctly.

    They reset the light, sugguested using 98ron unleaded which we did, biut again within 150 miles light on again.

    We took it elsewhere as there was a noise fom the water pump area and this was replaced under the warranty,( The cam belt was done at the same time)they checked the fault codes, reset the light but again it came on within the same mileage.

    Several weeks later a loud whiring noise could be heard which I thought was the alternator, and it was found to be overcharging the battery. They thought this may be triggering the EML to come on, but with a new alternator under the warranty a few weeks later the EML was on again, they said you have to take to Vauxhall.

    We did this, same fault codes appeared they had the car for an hour whilest we waited, but said you will have to bring it back again and leave for longer. Thjeir conclusion? we dont know what it is! May be the airflow meter, or maybe the ECU. I spoke to the warranty company and they wont pay without a firm diagnosis. The dealer said, we havent got a magic wand. Very helpfull. I contacted Vauxhall customer care several times, but they just kept saying go back to the dealer, we cant get involved the car is too old and way out of warranty.

    Nearly two years after having this car(The latest in many Vauxhalls owned) this problem is still here the EML is on permanently, and I cant seem to find anybody to help! The exhaust has been checked, there is no leaks from tyhat which may have triggered a fault code, so please please can anybody help??? look forward to hearing from somebody who knows something

    Telephone (07795) 104792 or e-mail elvetwilliams71@aol.com.

  2. Remove Advertisements
    MigWeb.co.uk
    Advertisements
     

  3. #2
    Moderator Nobbie's Avatar
    Join Date
    Nov 2001
    Location
    Hemel Hempstead
    Posts
    11,297
    Drives
    with blue lights
    Would be better posted in Mechanical and Electrical, not the test forum TBH.

    My money's on AMM, but if i could guess that right, i'd guess the lottery numbers.
    There are two things no man will admit he cannot do well: drive and make love.

    Stirling Moss.

  4. #3
    MIGWeb User
    Join Date
    Jan 2006
    Location
    crewe
    Posts
    357
    Drives
    corsa b 20xe
    had 1 in with that fault today, but it was saying bank 1 and 2, has it had an emmissions test as thats the easiest way to rule out the cat, going on past experience with these i'd try an air flow meter but its worth checking the cat 1st, not a big job to drop down and have a look inside, but start with an emmissions test, this 1 i had passed with flying colours so it kind of eliminated the cat(u have 2 pre cats,1 per bank with an o2 sensor before and after) and the normal cat a bit further back but theres no sensor after that 1

  5. #4
    MIGWeb User
    Join Date
    Jun 2006
    Posts
    2
    Drives
    Thread Starter

    Vectra GSi EML on

    Thanks for advice:- The car had MOT lfew days ago, flew through emmisions test.

    Have spoken to supplying dealer who has spoken to 3 people. They are going to change the airflow meter. We all hope this cures fault.

    We also have another GSi estate but 2.5 version 99 v reg. Never had this prob on this!

    However, this has a very high pitched whistle, even when the "Hooover" (LOL)has cut out on cold start. Any ideas on this one??

  6. #5
    MIGWeb User
    Join Date
    Jan 2006
    Location
    crewe
    Posts
    357
    Drives
    corsa b 20xe
    just on tickover? could be alternator noisy or something in that area? tensioner or a cambelt roller?

  7. #6
    MIGWeb User
    Join Date
    Dec 2004
    Location
    south wales
    Posts
    116
    Drives
    Astravan 2.5V6 210hp
    You need to get it looked at by someone who knows how to read an eobd device, vauxhall haven't a clue. The live data needs to be monitored so you can look at the fuel trims, the short term fuel trims should fluctuate around the zero mark. the long term fuel trim needs to be fairly close to zero ( this is the one that will bring your management light on)
    Resetting will only reset the fuel trims, and after so many miles the LT fuel trim will drift out causing the EML to come on.
    Many causes for this including air leaks on the manifold, LAmbda probes etc etc.
    You have not had enough alchohol if you can lie on the floor without holding on!!!

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts