c20let tapping at 1100 rpm when warm
+ Reply to Thread
Results 1 to 4 of 4

Thread: c20let tapping at 1100 rpm when warm

  1. #1
    MIGWeb User
    Join Date
    May 2007
    Location
    hampshire
    Posts
    81
    Drives
    cav gsi

    c20let tapping at 1100 rpm when warm

    hi guys just got my cav running again all seemed good for a few days but now if i hold the revs up at around 1100rpm the engine sounds its knocking?

    it doesnt do it when it idles or when its cold, only when warmed up, to me it sounds like a bit of piston-slap but not sure.

    also when i drove it it would do it when i come off the throttle but doesnt when im accelerating (i have stopped driving it now)

    its prob something simple but its stressing me out, the bottom end was purchased off her by a member but i was assured the rings and bearings were replaced, plus he had done a fair few miles on it without any problems, and upon inspection everything looked good too.

    HELP ME!!!!!! lol i wana drive my cav again

    please dont make me get the petrol and matches out

  2. Remove Advertisements
    MigWeb.co.uk
    Advertisements
     

  3. #2
    MIGWeb User
    Join Date
    May 2001
    Location
    South Wales
    Posts
    43,190
    Drives
    Nippy Cav Turbo

    Re: c20let tapping at 1100 rpm when warm

    is the engine running bigger pistons? i.e. weisco etc?
    I love MIG...MIG loves meeee...like one big gooOy F A M I L E E E

  4. #3
    MIGWeb User
    Join Date
    May 2007
    Location
    hampshire
    Posts
    81
    Drives
    cav gsi
    Thread Starter

    Re: c20let tapping at 1100 rpm when warm

    lol just relised ive put this in the wrong forum!
    any chance this could be moved?

    and adam, no there running standard pistons with standard bores mate

  5. #4
    MIGWeb User
    Join Date
    Mar 2010
    Location
    Stockport, Cheshire
    Posts
    378
    Drives
    Golf Mk4, AstraVan

    Re: c20let tapping at 1100 rpm when warm

    My friend's escort did a similar thing when the oil pressure relief valve on the oil pump was sticking so the pressure would be OK on revs and when cold but when hot it would knock after dropping the revs. Could just need an oil change with some engine flush in if it has been laid up.
    Good luck.
    “Speed has never killed anyone, suddenly becoming stationary… that’s what gets you.”

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts